Document Generation Timeouts on short running generation requests

Incident Report for DocFusion

Postmortem

In preparation for our scheduled release, we initiated a deployment to our Non-Live Blue/Green environment but due to a mis configuration in our infrastructure deployment code, this deployment resulted in unexpected interference from the Non-Live Production Environment with the Live Production Environment. We have implemented a permanent fix to avoid this from happening during future infrastructure deployments.

Posted Nov 25, 2025 - 15:16 SAST

Resolved

The issue has now been fully resolved.
Posted Nov 25, 2025 - 15:12 SAST

Monitoring

We identified root cause for the partial outage. Fix has been put in place and we are now monitoring the situation.
Posted Nov 25, 2025 - 14:47 SAST

Update

We are continuing to investigate this issue.
Posted Nov 25, 2025 - 14:10 SAST

Investigating

We are currently experiencing a high frequency of timeouts on short running document generation requests.
Posted Nov 25, 2025 - 14:10 SAST
This incident affected: Europe (DocFusion Platform/API's).